September 20, 2017, 10:44:33 am
Welcome, Guest. Please login or register.

Author Topic: Revelation Robotics  (Read 28957 times)

RevRobots

  • Roboteer
  • ****
  • Posts: 263
    • View Profile
Revelation Robotics
« on: February 05, 2015, 07:51:40 pm »
Hello All,
This is my plunge into the SPARC forum.
Here are my bots:
Sky Rocket
 
Status: Complete, Record: 4-6, Weapon: Servo Lifter, Competitions: Bot Blast 2014 0-2, and Franklin Institute 2014 2-2, Motorama 2015 2-2, Upcoming Competitions: None
Cornerstone,
 
Status: Complete, Record 17-8, Weapon: Wedge, Competitions Motorama 2015 2-2, Spring Fling 2015 3-2, Bot Blast 2015 3-2, Barn Battles 2015 5-0, Fall Brawl 2015 4-2. Upcoming Competitions: Motorama 2016 Titles: Motorama 2015 Antweight Rumble Champion, 3rd place at Spring Fling 2015, 2nd place at Fall Brawl 2015, And 1st Place at Barn Battles 2015.
The Ophidian,

Status: Complete, Record 5-8, Weapon: Spinning dado blade, Competitions: Motorama 2015 3-2, Bot Blast 2015 0-2, Fall Brawl 2015 1-2. Upcoming Competitions: Motorama 2016
Revelation,

Status: Building, Record 0-0, Weapon: FBS, Upcoming Competitions: none
Arrow,

Status: Complete, Record 3-5, Weapon: Thwacker, Competitions: Spring Fling 2015 1-2, Barn Battles 2-3. Upcoming Competitions: none
Justice,

Status: Complete, Record 6-3, Weapon: Overhead bar, Competitions: Bot Blast 2015 2-2, Barn Battles 2015 4-1. Upcoming Competitions: Motorama 2015?
Bulwark,

Status: Complete, Record 2-3, Weapon: Brutte Force, Competitions: Barn Battles 2015 2-3, Fall Brawl 2015 1-2. Upcoming Competitions: None
Any questions?

Adam
Revelation Robotics
« Last Edit: December 18, 2015, 03:56:43 pm by RevRobots »

Koolaid64

  • Roboteer
  • ****
  • Posts: 279
    • View Profile
Re: Revelation Robotics
« Reply #1 on: February 05, 2015, 08:15:34 pm »

RevRobots

  • Roboteer
  • ****
  • Posts: 263
    • View Profile
Re: Revelation Robotics
« Reply #2 on: February 05, 2015, 08:44:07 pm »
Thanks Kyle.

I will work on the pics right away.

Adam
Revelation Robotics

RevRobots

  • Roboteer
  • ****
  • Posts: 263
    • View Profile
Re: Revelation Robotics
« Reply #3 on: February 06, 2015, 03:00:57 pm »
I couldn't get it to work. Oh well here are the buildersdb pics:

Sky Rocket:

http://www.buildersdb.com/botdetails.asp?eventid=395&BotID=9677.jpg

Cornerstone:

http://www.buildersdb.com/botdetails.asp?eventid=395&BotID=9843.jpg

The Ophidian:

http://www.buildersdb.com/botdetails.asp?eventid=&BotID=9902.jpg

Revelation (shell):

http://www.buildersdb.com/botdetails.asp?eventid=&BotID=9916.jpg

Sorry for the bad pic of The Ophidian, I'll have a new one up soon.
Here is my old thread http://forums.delphiforums.com/cjrc/messages/?msg=3553.1, I think it will answer some of your questions.

Adam
Revelation Robotics
« Last Edit: February 06, 2015, 05:33:31 pm by RevRobots »

Koolaid64

  • Roboteer
  • ****
  • Posts: 279
    • View Profile
Re: Revelation Robotics
« Reply #4 on: February 06, 2015, 05:18:49 pm »
use the link that takes you to only the picture http://www.buildersdb.com/botpics/9677.jpg

zacodonnell

  • Roboteer
  • ****
  • Posts: 446
    • View Profile
Re: Revelation Robotics
« Reply #5 on: February 06, 2015, 05:27:53 pm »
That's a lot of bots to make in a short time.  How many are you expecting to actually run at Motorama this year?

RevRobots

  • Roboteer
  • ****
  • Posts: 263
    • View Profile
Re: Revelation Robotics
« Reply #6 on: February 07, 2015, 06:09:33 pm »
Hi Zac,

We are planing to run 3 robots: Sky Rocket, Cornerstone, and The Ophidian. And I am going to hopefully bring Revelation as a grudge bot.

All,

Here is a pic of Revelation. It uses servo drive, and a cake pan for a spinner.



Any questions or coments?

Adam
Revelation Robotics

RevRobots

  • Roboteer
  • ****
  • Posts: 263
    • View Profile
Re: Revelation Robotics
« Reply #7 on: February 10, 2015, 04:18:31 pm »
Hello All,

Yesterday I got the BESC for Revelation. I tested it and with the brushless, and it works very nicely. The only problem is that I put the shell on and brought it outside to test it and the motor seems to be over-loaded. :(

I will have to test it out on different voltages. I may have to run it on a 9v battery. But overall I'm very happy with the first test, the drive system worked nicely and the shell looked very balanced. It is also only about 1oz. over-weight. Once I get it working I'll post a test video.

Adam
Revelation Robotics

RevRobots

  • Roboteer
  • ****
  • Posts: 263
    • View Profile
Re: Revelation Robotics
« Reply #8 on: February 11, 2015, 03:27:47 pm »
Hello All,

I am having more trouble with Revelation (shell spinner). When I power up the brushless motor with the shell attached, the shell spins very slowly.  But, when I remove the shell, the brushless gets up to speed easily.  I tried attaching my brother's 2 oz. dado blade instead of the 6 oz. shell spinner, but that didn't make any difference.  I tried leveling up the battery voltage from 7.4v, to a 9v, to two 9v. That didn't work. Then I tried taking the servo drive off of the full voltage. That didn't work either. :(

So I'm out of ideas, do you guys have any? Here are the specs. for the motor and ESC.
http://www.hobbyking.com/hobbyking/store/__18967__D2822_17_Brushless_Outrunner_1100kv.html
http://www.hobbyking.com/hobbyking/store/__2161__TURNIGY_Plush_12amp_2A_BEC_BESC.html

Adam
Revelation Robotics

Koolaid64

  • Roboteer
  • ****
  • Posts: 279
    • View Profile
Re: Revelation Robotics
« Reply #9 on: February 11, 2015, 03:38:50 pm »
bump up to a  18 amp controller also try to belt drive it with about a 3:1 ratio just to make it easier on the motor to spin up.
« Last Edit: February 11, 2015, 06:57:38 pm by Koolaid64 »

zacodonnell

  • Roboteer
  • ****
  • Posts: 446
    • View Profile
Re: Revelation Robotics
« Reply #10 on: February 11, 2015, 06:39:51 pm »
When you say it doesn't work, what does it do? Does it fail to spin at all, spin slowly, get really hot, shoot flames out (I hope not!)?

If it is just spinning very slowly it could be your battery can't source the current you need. two 9v batteries together might be able to source enough for a little while but the 7.4v lipo is more likely to work.  Does any part of the system get hot?

-Zac

RevRobots

  • Roboteer
  • ****
  • Posts: 263
    • View Profile
Re: Revelation Robotics
« Reply #11 on: February 13, 2015, 08:04:06 am »
Zac,

The brushless motor spins very slowly, I mean Slice slow. No I don't think any part of the system gets hot.

@Kyle,
Thanks for the suggestion. I guess Revelation will be there for show & tell.

All,
This is my one year anniversary of building Combat Robots!:D
It all started out with Destructor.



 I happened to be building him during Moto' last year without knowing it. And yes, he is made out of wood and cardboard, but it had servo switch control and some speedy gearboxes.
Thanks for all of the advice! :D

Adam
Revelation Robotics

zacodonnell

  • Roboteer
  • ****
  • Posts: 446
    • View Profile
Re: Revelation Robotics
« Reply #12 on: February 13, 2015, 06:00:25 pm »
Zac,

The brushless motor spins very slowly, I mean Slice slow. No I don't think any part of the system gets hot.


Could you possibly take a video of it spinning without the shell and with the shell using the 7.4v lipo? That should help us diagnose it. What you describe sounds like it might be a battery problem. What is the capacity (in mah) of your lipo pack?  Do you know the C rating? A link to the battery would work too.

-Zac

RevRobots

  • Roboteer
  • ****
  • Posts: 263
    • View Profile
Re: Revelation Robotics
« Reply #13 on: February 15, 2015, 03:56:29 pm »
Hi Zac,

Here are the specs. 7.4v Lipo, 460mAh, and 20c. Here is the link. http://www.fingertechrobotics.com/proddetail.php?prod=R-2S-mAh

Also here is a video:

https://vimeo.com/119694592

Any Last minute suggestions? Because I want to call a hobby shop that is (relatively) close to me to see if they have the 18 amp controller that Kyle mentioned.

Adam
Revelation Robotics

Koolaid64

  • Roboteer
  • ****
  • Posts: 279
    • View Profile
Re: Revelation Robotics
« Reply #14 on: February 15, 2015, 04:26:19 pm »
It may just be to much load on the motor/controller. I had the turnigy 12amp in brisinger at franklin and the startup was awful so I switched back to the 18amp. I think its just a timing issue with the software.